Back to overview
Degraded
Our incident response team is investigating the ongoing incident
Sep 10 at 12:41pm EDT
Affected services
MaintainX App
REST API
GraphQL API
Website
Resolved
Sep 11 at 01:23pm EDT
Late Update. Everything is back to normal.
Affected services
Created
Sep 10 at 12:41pm EDT
We’re experiencing technical issues that affect the performance or availability of our platforms. We’ll continue to post updates as we work to restore service.
Affected services