Back to overview
Degraded

Our incident response team is investigating the ongoing incident

Sep 10 at 12:47pm EDT
Affected services
MaintainX App
REST API
GraphQL API
Website

Resolved
Sep 10 at 01:10pm EDT

Root cause was identified and corrected. Thank you for your patience.

Created
Sep 10 at 12:47pm EDT

We’re experiencing technical issues that affect the performance or availability of our platforms. We’ll continue to post updates as we work to restore service.