Back to overview
Downtime
Our incident response team is investigating the ongoing incident
Sep 15 at 10:35am EDT
Affected services
MaintainX App
REST API
GraphQL API
Resolved
Sep 15 at 10:42am EDT
We’re experiencing technical issues that affect the performance or availability of our platforms. We’ll continue to post updates as we work to restore service.
Affected services
Created
Sep 15 at 10:35am EDT
We’re experiencing technical issues that affect the performance or availability of our platforms. We’ll continue to post updates as we work to restore service.
Affected services