Back to overview
Degraded

Issue with Report Exporting

Mar 02, 2026 at 01:45pm UTC
Affected services
MaintainX App

Resolved
Mar 02, 2026 at 02:37pm UTC

Report builder is back online

Created
Mar 02, 2026 at 01:45pm UTC

We currently have issues with report exporting and it's being investigated.