Back to overview
Degraded

Reporting Degradation Due to Third-Party Outage

Apr 22, 2026 at 9:59pm UTC
Affected services
MaintainX App

Resolved
Apr 22, 2026 at 10:17pm UTC

Reporting functionality has been restored as the third-party provider has resolved the issue.

Created
Apr 22, 2026 at 9:59pm UTC

Reporting functionality is currently degraded due to an ongoing issue with a third-party provider. Some users may experience errors when accessing reports. We are actively monitoring the situation while the provider investigates the issue.